Sift services are impacted due to an issue experienced by our cloud provider.

Incident Report for Sift

Resolved

All Sift services are operational. Thank you for your patience.
Posted Jun 12, 2025 - 15:01 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 12:23 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 12:23 PDT

Investigating

Sift services are impacted due to an issue experienced by our cloud provider. We apologize for any inconvenience.
Posted Jun 12, 2025 - 11:45 PDT
This incident affected: Console, API, Score, and Workflows.