Intermittent Console Slowness
Incident Report for Sift
Resolved
As of 12 noon PST the console back to normal load times. Please contact support@sift.com if you are still noticing any issues.
Posted Jan 14, 2020 - 12:50 PST
Investigating
We're currently experiencing intermittent console slowness. We're investigating and working to resolve the issue as quickly as possible.
Posted Jan 14, 2020 - 10:59 PST
This incident affected: Sift Console.